China Zoom Issues
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 15:18 EDT
Investigating
For students experiencing issues with Zoom in China contact cnsupport@zoomus.zendesk.com.
Posted Sep 25, 2019 - 15:04 EDT
This incident affected: Zoom Video Communications, Inc. Zoom Meetings.