Online Services email is interrupted
Resolved
Incident resolved. Mail reported flowing as of 12:55 PM.
Posted 4 months ago. Mar 09, 2019 - 15:04 EST
Identified
Online Services (dceweb.harvard.edu) is unable to send email at this time.
Posted 4 months ago. Mar 09, 2019 - 10:13 EST
This incident affected: Online Services.