Harvard Online Support HelpDesk phones are down
Resolved
All phone lines are working again.
Posted 12 months ago. Apr 25, 2017 - 16:58 EDT
Identified
The phone system in 125 Mt Auburn St. is down. Work is being done to restore it as soon as possible. In the meantime, please direct all online support issues to academictechnology@dce.harvard.edu.
Posted 12 months ago. Apr 25, 2017 - 13:16 EDT