Videos unavailable
Resolved
This incident has been resolved.
Posted 5 months ago. May 23, 2017 - 12:08 EDT
Monitoring
Video authentication is now working.
Posted 5 months ago. May 23, 2017 - 11:35 EDT
Investigating
We are having a problem with our authentication system. Users are unable to view videos from matterhorn.dce.harvard.edu, including public videos.
Posted 5 months ago. May 23, 2017 - 11:25 EDT