MyDCE and Online Services Maintenance
Resolved
Maintenance on the MyDCE and Online Services sites was completed well ahead of schedule. Both sites are now available to use as normal.
Posted Apr 13, 2024 - 12:09 EDT
Update
Maintenance on the MyDCE and Online Services sites was completed well ahead of schedule. Both sites are now available to use as normal.
Posted Apr 13, 2024 - 12:09 EDT
Investigating
MyDCE and Online Services sites are down for maintenance until 6 PM, Eastern Time on Saturday, April 13. Canvas courses, Zoom meetings, and course videos are still available by accessing Canvas directly at canvas.harvard.edu.
Posted Apr 12, 2024 - 19:46 EDT
This incident affected: MyDCE and Online Services.