Video Courses Access Problems

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 22:27 EDT

Update

The issue has been resolved.
Posted Jun 25, 2025 - 18:30 EDT

Investigating

We are experiencing problems with our authorization system which is preventing some students from accessing their course videos. Please bear with us as we work to resolve this problem.
Posted Jun 25, 2025 - 16:58 EDT
This incident affected: Video Courses.