External Email Routing Problem
Resolved
Harvard's central IT department has resolved this issue.
Posted Feb 14, 2024 - 19:41 EST
Monitoring
Harvard central IT reports "The issue impacting email delivery has been resolved by our vendor and email delivery is fully operational for all users." Email sent to academictechnology@dce.harvard.edu and webconference@dce.harvard.edu before 2:00 PM today may need to be resent.
Posted Feb 14, 2024 - 15:55 EST
Identified
Harvard's central IT department is reporting problems routing external emails. Two of DCE's support email addresses academictechnology@dce.harvard.edu and webconference@dce.harvard.edu are unable to receive email.
Posted Feb 14, 2024 - 13:31 EST