HarvardKey login unavailable for Online Services
Resolved
The HarvardKey login for Online Services has been restored.
Posted Aug 12, 2018 - 16:18 EDT
Investigating
The HarvardKey login option for Online Services is currently unavailable. Users can still access Online Services using their DCE ID and PIN.

If users do not remember their DCE ID and PIN, they can select the recovery options under the "Login with DCE ID and DCE PIN" box on the website.
Posted Aug 12, 2018 - 14:21 EDT
This incident affected: Online Services.