Lecture video access still experiencing login difficulties
Resolved
HarvardKey service is fully restored.
Posted 8 months ago. Feb 08, 2017 - 08:26 EST
Update
Canvas login access has been restored. Lecture video access is still experiencing login difficulties.
Posted 9 months ago. Feb 07, 2017 - 21:37 EST
Update
Canvas login access has been restored. Lecture video access is still experiencing login difficulties.
Posted 9 months ago. Feb 07, 2017 - 21:34 EST
Investigating
Go to Online Services (dceweb.harvard.edu), login as usual and find your class video in the lower right.
Posted 9 months ago. Feb 07, 2017 - 19:27 EST