Harvard Online Support HelpDesk Phones Are Down
Resolved
Harvard Online Support experienced a phone system outage at 4:30 PM that lasted several hours. Phones and voicemail are now confirmed to be working. Thank you for your patience.
Posted 8 months ago. Apr 26, 2017 - 21:10 EDT
Update
The phone system issue may take a few hours to resolve and we now know that it is also affecting voicemail. If you have any problems, please email us at academictechnology@dce.harvard.edu. We apologize for the inconvenience.
Posted 8 months ago. Apr 26, 2017 - 18:23 EDT
Investigating
The phone system for Harvard Online Support is currently experiencing problems. Incoming calls may be directed straight to voicemail. If you need immediate assistance, please email academictechnology@dce.harvard.edu.
Posted 8 months ago. Apr 26, 2017 - 16:40 EDT